1. Users must install app version 2.1.14 (released 6/2/19) or higher.
  2. Users must accept push notifications from Buddy Punch (prompted when first installing or updating the app to version 2.1.14 or higher)
  3. Users must log in once with their credentials.

To view this article in full outside of the chat window, please click here.

Did this answer your question?